AppImage翻车 解决报错过程version ZLIB_1.2.9 not found



在录上一个视频过程中,演示了一个18.04打包的AppImage在16.04上运行居然翻车了,这个视频就是找一下翻车原因,以及如何解决。

sscom-v0.4-linux-x86_64.AppImage: /lib/x86_64-linux-gnu/libz.so.1: version `ZLIB_1.2.9′ not found (required by /tmp/.mount_sscom-Gvcv39/usr/bin/../lib/libpng16.so.16)
AppImage: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.25′ not found (required by /tmp/.mount_sscom-Gvcv39/usr/bin/../lib/libudev.so.1)

Likes – 1, Dislikes – 0

source